Problems with developer guide

Hello. I want to change some code in biodynamo source, so I’ve used this guide to install it on my machine: https://biodynamo.org/docs/devguide/build/. I wrote:
git clone https://github.com/BioDynaMo/biodynamo.git
cd biodynamo

./prerequisites.sh all

mkdir build
cd build

cmake ..
make -j 8.
Then I go into a project folder, say cell_division from here: https://biodynamo.org/docs/userguide/first_steps/. I do biodynamo build && biodynamo run and get the following log (see this file on google drive: out.txt - Google Drive). I can’t understand what the problem can be, please, help me.

Hello!
I’ve just taken a look at your log. I saw that the following lines appear:

/home/ummagumma/biodynamo-v1.0.8/include/[...]
/home/ummagumma/biodynamo/build/include/[...]
  1. So I’m not sure if you have two versions of BioDynaMo installed, but for instance your compiler complains about L2F which is a feature in the latest master and is not there in v1.0.8. I’d recommend to get rid of the multiple repositories first if you don’t have any strong reasons for having it. Make sure that the one that you want to use is up to date with the latest master, e.g.
rm -rf /home/ummagumma/biodynamo-v1.0.8
cd /home/ummagumma/biodynamo
git checkout master
git pull
  1. If I was in your position I’d rebuild BioDynaMo to be on the safe side. (N = number of available processes)
cd /home/ummagumma/biodynamo/build
make cleanbuild (or ninja cleanbuild)
cmake ..
make -j N
  1. make sure you source biodynamo, do this any time you start a new terminal as well
. /home/ummagumma/biodynamo/build/bin/thisbdm.sh
  1. Verify that biodynamo has been installed properly by running the biodynamo-unit-tests in biodynamo/build/bin. There should be no errors.

  2. Once you’ve tried those steps, try to again run the cell devision.

cd
biodynamo demo cell_division
cd cell_division
biodynamo run

Hope that help, Tobias

Now it works perfectly fine. Thank you very much!!